Zammad

Aus Hostsharing Wiki
Zur Navigation springen Zur Suche springen


Diese Seite muss überarbeitet werden

Diese Seite wurde als Baustelle gekennzeichnet, weil sie überarbeitet werden muss. Eine Begründung dafür findest du auf der Diskussionsseite. Bitte hilf mit, diese Seite zu verbessern!

Installation

sollte nach einer Hostsharing-Variante der folgenden Beschreibung funktionieren:

Zammad Upgrade

killall -u $USER
killall -u $USER 9

cp -a zammad zammad-old
cd zammad
wget -O - https://ftp.zammad.com/zammad-latest.tar.gz |tar -xvvz
bundle install --without test development mysql

	Geht nicht, Ruby 2.2.5 fehlt!

cd
rbenv install 2.5.5

	Geht nicht, Rbenv ist zu alt!

cd ~/.rbenv/plugins/ruby-build
git pull
cd
rbenv install 2.5.5
rbenv global 2.5.5
rbenv local 2.5.5

cd zammad
gem install bundle
gem install bundler
bundle install --without test development mysql

Geht nicht, Bundler 1.17.x wird gebraucht.

gem install bundler==1.17.3

	Geht auch nicht.
	Dann hacken wir das mal versuchsweise ins Lock.

vim Gemfile.lock

bundle install --without test development mysql

	Es fehlen Libs.
	HS bitte installieren...
	[...]
	Danke!

bundle install --without test development mysql
export RAILS_ENV=production
rake db:migrate
rake assets:precompile

/usr/bin/supervisord -c $HOME/supervisor/etc/supervisord.conf