Loomio installieren: Unterschied zwischen den Versionen

Aus Hostsharing Wiki
Zur Navigation springen Zur Suche springen
(initiale Version, WIP)
 
Zeile 96: Zeile 96:
 
     xyz00-loomio@h20:~/loomio$ rake db:setup
 
     xyz00-loomio@h20:~/loomio$ rake db:setup
 
     xyz00-loomio@h20:~/loomio$ rake db:migrate
 
     xyz00-loomio@h20:~/loomio$ rake db:migrate
 +
 +
    rake db:schema:load
 +
    ActiveRecord::StatementInvalid: PG::InsufficientPrivilege: ERROR:  permission denied to create extension "citext"

Version vom 6. Mai 2021, 06:12 Uhr

Das ist ein Artikel in Arbeit! Timotheus, 6. Mai 2021

{{{3}}}


Über

https://www.loomio.org/

what is loomio: 3 Minute video. https://www.youtube.com/embed/Zlzuqsunpxc

https://github.com/loomio/loomio/releases

TODO https://help.loomio.org/en/dev_manual/setup_dev_environment/

Es ist in Ruby geschrieben, daher Orientierung an https://wiki.hostsharing.net/index.php?title=Installation_Openproject

Vorbereitungen

Installation von Ruby

Weiterhin benötigt Loomio eine geeignete Version der Programmiersprache Ruby:

Die Version ist in https://github.com/loomio/loomio/blob/master/.ruby-version zu finden.

   xyz00-project@h20:~/doms/projekt.example.com$ cd
   xyz00-project@h20:~$ git clone https://github.com/sstephenson/rbenv.git ~/.rbenv
   xyz00-project@h20:~$ touch .profile
   xyz00-project@h20:~$ chmod u+x .profile
   xyz00-project@h20:~$ echo 'export PATH="$HOME/.rbenv/bin:$PATH"' >> ~/.profile
   xyz00-project@h20:~$ echo 'eval "$(rbenv init -)"' >> ~/.profile
   xyz00-project@h20:~$ source ~/.profile
   xyz00-project@h20:~$ git clone https://github.com/sstephenson/ruby-build.git ~/.rbenv/plugins/ruby-build
   xyz00-project@h20:~$ rbenv install 2.7.3
   xyz00-project@h20:~$ rbenv rehash
   xyz00-project@h20:~$ rbenv global 2.7.3

Als Test bitte aufrufen: ruby -v

Die Anzeige sollte etwa das Folgende enthalten: ruby 2.7.3pXYZ (....) [x86_64-linux]

Installation von Node

   curl -o- https://raw.githubusercontent.com/nvm-sh/nvm/v0.38.0/install.sh | bash
   export NVM_DIR="$HOME/.nvm"
   source $NVM_DIR/nvm.sh
   nvm install stable
   nvm alias default stable

Installation

Installation der Anwendung

   git clone https://github.com/loomio/loomio.git
   cd loomio
   # check for latest release at https://github.com/loomio/loomio/releases
   git checkout -b v2.7.8 v2.7.8
   source ~/.profile
   export NVM_DIR="$HOME/.nvm"
   source $NVM_DIR/nvm.sh
   #gem update --system
   bundle install
   cd vue; npm install && cd ..

Konfiguration von Loomio

Erstelle eine Konfiguration für den Datenbank-Zugriff in der Datei config/database.yml

   xyz00-project@h20:~$ cd ~/loomio
   xyz00-project@h20:~/loomio$ cp config/database.yml.example config/database.yml

In der neuen Datei database.yml wird die mit HSAdmin angelegte PostgreSQL-Datenbank eingetragen:

   production:
     adapter: postgresql
     encoding: unicode
     host: localhost
     database: xyz00_loomio (wie oben angegeben)
     pool: 10
     username: xyz00_dbuser (wie oben angegeben)
     password: meinPasswort (wie oben angegeben)

Einen geheimen Schlüssel erzeugen

   xyz00-loomio@h20:~$ cd ~/loomio
   xyz00-loomio@h20:~/loomio$ EDITOR=vim ./bin/rails credentials:edit

Den Editor vim mit Speichern verlassen: Esc Taste drücken, dann eingeben: :wq und Enter drücken

   xyz00-loomio@h20:~/loomio$ export RAILS_ENV="production"
   xyz00-loomio@h20:~/loomio$ echo "export SECRET_KEY_BASE=$(rake secret)" >> ~/.profile

Initialisiere Datenbank und erzeuge Web-Ressourcen

   xyz00-loomio@h20:~$ cd ~/loomio
   xyz00-loomio@h20:~/loomio$ export RAILS_ENV="production"
   xyz00-loomio@h20:~/loomio$ source ~/.profile

PROBLEM: beide Befehle gehen nicht:

   xyz00-loomio@h20:~/loomio$ rake db:setup
   xyz00-loomio@h20:~/loomio$ rake db:migrate
   rake db:schema:load
   ActiveRecord::StatementInvalid: PG::InsufficientPrivilege: ERROR:  permission denied to create extension "citext"